13个常见的 WordPress 块编辑器问题以及如何修复它们

13个常见的 WordPress 块编辑器问题以及如何修复它们

您在使用 WordPress 块编辑器时遇到过错误吗?

WordPress 在 2019 年用名为 Gutenberg 的全新内容编辑器取代了旧的经典编辑器。该编辑器使用块在 WordPress 中创建内容。然而,有时,在使用它时可能会遇到恼人的问题。

在本文中,我们将分享如何解决最常见的WordPress块编辑器问题,以便您改进工作流程。

13个常见的 WordPress 块编辑器问题以及如何修复它们

什么是 WordPress 块编辑器?

WordPress 块编辑器(或 Gutenberg)是WordPress 5.0 版本中引入的内容编辑器。从那时起,WordPress 改进了编辑器并添加了新的特性和功能。

与经典编辑器相比,它提供了更多的自定义功能。您可以使用不同的块向内容添加不同的元素,而无需编辑代码来更改外观和样式。

它试图通过模仿WordPress 主题的相同字体和颜色来实时显示您的博客和页面的外观。

例如,您可以使用图像块将图片添加到博客文章中。另外,您还可以使用该块获得图像样式、大小、对齐方式等选项。

添加图像块

除此之外,许多WordPress 插件都会将其块添加到内容编辑器中。这使得只需点击几下即可轻松嵌入表单、社交媒体源和内容表格等内容。

也就是说,块编辑器并不完美。与任何其他 WordPress 插件一样,您可能会遇到不同的错误或错误。

以下是内容编辑器中的一些常见问题。

1.修复WordPress块编辑器不工作错误

用户面临的最常见问题之一是“WordPress 块编辑器无法工作”。

出现此错误的原因有多种。例如,这可能是因为旧的、过时的主题、有缺陷的插件或其他技术错误。

如果您网站上的设置配置错误,例如在创建用户配置文件时禁用可视化编辑器,则 WordPress 块编辑器也可能无法工作。

您可以通过 WordPress 仪表板转到“用户”»“个人资料”来检查这一点。从这里,只需确保未选择“写作时禁用可视化编辑器”选项即可。

写作时禁用可视化编辑器

如果问题仍然存在,那么您可以尝试停用网站上的所有插件。这应该有助于排除插件可能引起的任何冲突并阻止块编辑器工作。

解决此问题的另一种方法是更新您的 WordPress 主题。过时的主题可能会导致块编辑器无法工作错误。您可以查看我们的指南,了解如何在不丢失数据和自定义的情况下更新 WordPress 主题。

2. WordPress 块编辑器不断崩溃

一些用户面临的另一个常见问题是 WordPress 块编辑器意外崩溃。

当它崩溃时,您将看到“编辑器遇到意外错误”错误消息。然后 WordPress 将显示 3 个选项,包括尝试恢复、复制帖子文本和复制错误。

块编辑器崩溃了

造成此问题的原因可能有多种。例如,插件可能会破坏块编辑器并显示此错误,或者您的 WordPress 版本不是最新的。

您可以通过停用所有插件并一一重新激活它们来解决此问题。另一个修复方法是将 WordPress 更改为默认主题,例如“二十二十二”,然后查看问题是否仍然存在。

如果检查 WordPress 插件和主题后仍然遇到此问题,请尝试更新 WordPress 版本并清除 WordPress 缓存。

3. 删除内容编辑器中的无效 JSON 错误

当您编辑博客文章或页面时,单击块编辑器中的“更新”按钮时可能会出现“响应不是有效的 JSON 响应”错误。

在块编辑器中查看 JSON 错误

当您在WordPress 博客上编辑帖子时,WordPress 会在后台与网站服务器持续通信。当 WordPress 无法接收服务器的响应或响应不是 JSON 格式时,会导致此错误。

以下是您可能会收到无效 JSON 错误的一些原因以及解决方法:

  • 检查设置中的 WordPress URL – 您需要确保站点设置中的 WordPress 地址和站点地址正确。只需转到“设置”»“常规” 页面并检查 URL 是否相同。如果站点地址不同,可能会触发 JSON 错误。
确保 WordPress 和站点地址相同
  • 修复 WordPress 中的永久链接设置 – 在 WordPress 中,您可以为页面和帖子设置 SEO 友好的 URL。但是,不正确的设置可能会使块编辑器难以获得有效的 JSON 响应。只需确保选择正确的永久链接格式即可。
  • 检查 WordPress .htaccess 文件设置 – .htaccess 文件用作 WordPress 中的配置文件,用于管理 SEO 友好的 URL(永久链接)。通常,WordPress会自动重新生成并更新它。但是,不正确的设置或过时的 .htaccess 文件可能会导致 JSON 错误。
  • 请参阅 REST API 调试日志 –  REST API是 WordPress 用于与站点服务器进行通信的一组技术。JSON 错误也可能意味着 REST API 遇到错误。您可以通过在 WordPress 的“站点运行状况”页面上查看 REST API 日志来检查这一点。
  • 尝试停用所有插件 – 不同 WordPress 插件之间的冲突也可能导致无效的 JSON 错误。尝试停用网站上的所有插件,看看错误是否再次出现。
  • 切换到经典编辑器 – 如果您仍然无法解决 JSON 错误,那么您可以切换回 WordPress 中的经典编辑器。旧的内容编辑器不依赖 REST API 从网站服务器获取 JSON 响应。

要详细了解这些技巧,请参阅我们的关于如何修复 WordPress 中的无效 JSON 错误的指南。

4.解决更新失败/发布失败错误

在 WordPress 块编辑器中更新或发布博客文章或页面时,您可能会看到的另一个错误是:“更新失败。” 您可能处于离线状态。

当 WordPress REST API 无法与WordPress 数据库通信时,就会出现此问题。

更新失败错误

如果块编辑器无法发送和接收来自WordPress 托管数据库的请求,则站点的不同部分将无法运行。这包括块编辑器。

如果您未连接到互联网或失去连接,REST API 可能会停止工作。要解决此问题,请确保您的互联网连接正常工作,然后尝试更新或发布您的页面。

除此之外,您可以从 WordPress 仪表板转到工具 » 站点运行状况并查看 REST API 日志。如果 REST API 存在问题,您将在“建议改进”部分看到它。

查看站点健康状况

错误日志将显示 REST API 发生的情况,并可能为您提供有关可能导致问题的原因的线索。

有关修复此问题的信息,您可以查看我们的如何修复 WordPress 更新失败错误的指南。

5. 添加或删除 WordPress 块之间的空格

使用WordPress 块编辑器创建自定义页面和帖子时,您可能会注意到块之间的空间过多或过少。

通常,间距由您的 WordPress 主题控制。但是,块编辑器中的一些选项还可以让您控制页面布局并提供更好的用户体验。

例如,您可以添加间隔块来添加空格。只需单击“+”按钮并在内容中的任意位置添加间隔块即可。

向页面添加间隔块

这样,您可以在块之间添加额外的空间。

WordPress 还允许您调整间隔块的大小。您可以通过向上或向下拖动块来使其变大或变小。

调整间隔块的大小

如果您想删除块之间的额外空白,那么您需要在 WordPress 主题中输入自定义 CSS或使用CSS Hero等 CSS 插件。

该插件允许您编辑网站的 CSS,而无需编辑代码。它提供了不同的间距选项,您可以使用它们来调整块之间的空白空间。

CSS Hero 更改下边距

您还可以使用SeedProd在 WordPress 中创建自定义页面并完全控制设计。

要了解更多信息,请参阅我们有关如何添加或删除 WordPress 块之间的空白的指南。

6. 复制和粘贴内容而不会出现格式问题

您是否注意到,当您将桌面应用程序或网页中的内容复制并粘贴到块编辑器中时,最终也会粘贴不需要的格式?

您会发现粘贴内容的字体和颜色与您的 WordPress 主题不匹配。如果您使用 Microsoft Word 或Google Docs编写内容然后将其输入块编辑器,则这种情况很常见。

保持原始格式的一些简单技巧包括使用 Word 和 Google Docs 标题样式。这样,当您将内容粘贴到块编辑器中时,WordPress 会自动选择标题级别。

除此之外,您应该在粘贴内容后检查页面或帖子的HTML 代码。在 WordPress 内容编辑器中,您可以选择一个块,然后单击 3 个垂直点选项。

从下拉菜单中,只需选择“编辑为 HTML”选项。

在 WordPress 块编辑器中切换到块的 HTML 视图

这样,您应该能够找到任何格式错误,例如不正确的粗体和斜体、不需要的文本等等。

有关更多详细信息,您可以参阅我们的指南,了解如何在 WordPress 中复制和粘贴而不出现格式问题。

7.修复WordPress中的图片上传问题

接下来,在 WordPress 块编辑器中上传图像时,您可能会看到错误。这是WordPress 中最常见的图像问题之一。

出现此错误的主要原因是由于文件权限不正确。您的所有网站文件都存储在您的网络托管服务上,并且需要特定的文件和目录权限才能工作。

如果这些权限不正确,可能会阻止 WordPress 读取文件并将其上传到托管服务器。因此,您会注意到上传后图像将从媒体库中消失,或者您可能会看到一条错误消息:

‘Unable to create directory wp-content/uploads/2019/04. Is its parent directory writable by the server?’

要解决此问题,您需要编辑文件权限。您可以使用FTP 客户端并访问 /wp-content/ 文件夹。从这里,您可以右键单击该文件夹并更改文件权限。

检查 WP-Content 文件夹的文件权限

请按照我们关于如何修复 WordPress 中的图像上传问题的分步指南,了解有关此修复的更多信息。

8.修复HTTP图片上传错误

在 WordPress 块编辑器中上传图像时可能遇到的另一个问题是 HTTP 错误。

当您在媒体库中上传图像时,WordPress 将显示一般的“HTTP”错误,并且您将无法看到图片的预览。

HTTP 图片上传错误

有多种原因可能导致此问题。令人沮丧的是,错误消息没有提供太多有关实际原因的线索。

要解决这个问题,您可以尝试很多方法。首先,您只需等待几分钟,然后尝试重新上传图像。有时,您的网站服务器可能会遇到流量异常和服务器资源不足等问题。

除此之外,您可以增加WordPress 内存限制并防止内存不足导致 HTTP 错误。您可以尝试的其他操作包括更改 WordPress 使用的图像编辑器库和编辑 .htaccess 文件。

此外,您的登录名可能已过期,有时,通过转到登录屏幕并再次输入您的用户名和密码,此错误就会消失。

您可以在我们关于如何修复 WordPress 中的 HTTP 图像上传错误的指南中详细阅读这些技巧。

9. 删除 WordPress 中错过的计划发布错误

您是否知道 WordPress 提供了一个内置选项来安排博客文章?

在 WordPress 内容编辑器中,您可以更改发布博客文章的日期和时间。但是,有时您安排的内容可能无法在设定的时间发布。

帖子可以立即发布或计划在将来上线

出现此错误的主要原因是WordPress托管环境或插件冲突。WordPress 使用一种名为“cron”的技术来稍后自动发布您的帖子。

如果插件或网站托管服务器影响 cron 作业,则会导致 WordPress 中出现错过计划发布错误。

您可以通过检查 WordPress 网站的时区来解决此问题。您网站的时区可能与您想要用于安排博客的时区不匹配。

只需从 WordPress 管理面板前往“设置”»“常规” ,然后向下滚动到“时区”部分。

编辑时区设置

您还可以尝试通过清除 WordPress 缓存并增加 WordPress 内存限制来解决此问题。

请参阅我们的指南,了解如何修复 WordPress 中错过的计划发布错误。

10.修复 WordPress 块编辑器中的对齐问题

您可能会遇到的另一个常见的 WordPress 块编辑器是您的内容和图像可能未正确对齐。

例如,假设您向博客文章添加了项目符号列表并将其居中对齐。但是,在编辑帖子时,列表在块编辑器中显示为左对齐。类似地,中心对齐的图像块可能看起来左对齐或右对齐。

如果您在 WordPress 网站上安装并激活了古腾堡插件,那么它可能会导致块对齐问题。我们建议您停用古腾堡插件并查看是否可以解决问题。

另一个解决方案是为您想要居中对齐的文本添加以下自定义 CSS 代码:

1

2

3

.has-text-align-center {

  text-align: center;

}

您还可以查看我们有关如何在 WordPress 块编辑器中添加和对齐图像的指南。

11.解决Facebook缩略图不正确的问题

您是否注意到,当您在 Facebook 上分享文章时,帖子缩略图不正确?

该问题可能是由插件冲突、内容交付网络 (CDN)问题或缺少 Facebook 的开放图谱元标记引起的。

现在,这不是您在 WordPress 块编辑器中看到的问题。但是,您可以使用内容编辑器为 Facebook 指定 Open Graph 图像。

您可以使用多合一 SEO (AIOSEO)插件来快速解决问题。它是WordPress 最好的 SEO 插件,可帮助您针对搜索引擎和社交媒体优化您的网站。

激活后,您将在 WordPress 内容编辑器中看到 AIOSEO 设置元框。只需前往“社交”选项卡即可。

前往社交标签

接下来,您可以向下滚动到“图像源”部分。

从下拉列表中,您可以选择分享文章时在 Facebook 和其他社交媒体网站上显示的图像。

选择图像源

您可以按照我们的指南了解如何修复 WordPress 中的 Facebook 错误缩略图问题,并了解解决此问题的其他方法。

12. 修复 Facebook 和 Instagram oEmbed 问题

您将面临的另一个与社交媒体相关的块编辑器问题是将 Facebook 和 Instagram 内容添加到 WordPress。

过去,您可以轻松地将 Instagram 或 Facebook 的帖子嵌入 WordPress 中。然而,Facebook 改变了 oEmbed 现在的工作方式。

您无法再在 WordPress 中嵌入视频、图像、更新和其他内容。相反,它将显示内容的纯 URL。

WordPress 中的 oEmbed 错误示例

您可以使用Smash Balloon等社交媒体 WordPress 插件轻松解决此问题。它可以帮助您使用 oEmbed 轻松嵌入 Facebook 和 Instagram 的内容,您还可以在您的网站上显示社交媒体源。

有关更多详细信息,请参阅我们有关如何修复 WordPress 中的 Facebook 和 Instagram oEmbed 问题的指南。

13. 无法在块编辑器中查看嵌入内容预览

这是 WordPress 5.7 版本中提出的问题。每当您嵌入来自 YouTube和Vimeo 的视频或添加来自 Spotify 和 SoundCloud 的音频时,预览都不会出现在块编辑器中。

相反,您只会看到块中写入“预览不可用”或“此块遇到错误,无法预览”。这个问题的主要原因是默认的延迟加载功能。

在WordPress 5.5中,iFrame 默认情况下是延迟加载的,这意味着在访问者向下滚动到内容位置之前,不会加载图片等嵌入内容。

解决此问题的一个简单方法是更新您的 WordPress 版本。此错误已得到解决。如果您使用的是 5.7 或更低版本,我们强烈建议您将 WordPress 更新到最新版本。

我们希望本文能帮助您了解常见的块编辑器问题以及如何解决这些问题。您可能还想查看我们关于常见 WordPress 错误及其修复方法的指南,以及针对初学者的 WordPress SEO 终极指南

标签:

创建强大易用的WordPress网站

获得强大的吾店云WordPress网站,将自己从技术操作中解放出来,集中精力于网站构建、内容发布、营销转化和产品销售。

关于

解决方案

©2018 - 2024 吾店云

//]]>